【vm一键端基础】VMware低版本软件打开高版本软件生成的镜像时,提示版本不兼容 的解决办法

作者 : gm 本文共556个字,预计阅读时间需要2分钟 发布时间: 2022-09-27 共377人阅读

我们在下载使用各种 VM一键端的时候,经常会遇到本地VMware软件版本低于镜像版本的问题,

会提示“是由VMware产品创建,但该产品与此版VMware Workstation不兼容,因此无法使用。”

这是因为VMware软件都是向下兼容,但是不会向上兼容,如果你电脑上的虚拟机版本低于镜像生成的版本,那么就可能出现这个提示。

遇到这种情况,很好解决,只需要手工修改一个文件即可。

只需要找到这个镜像文件夹里面 的 vmx 文件,用记事本打开,(网游单机网-藏宝湾www.cangbaowan.top)

修改virtualHW.version = “xx”  这一行里面的数字,比如修改成 10 ,那么就是兼容VMware 10 以上版本

建议改为10 就行了, 可以设置为 15  12 之类的,千万别设13,因为没有13这个版本!

找到镜像文件夹里面 后缀名是 .vmx 的文件,右键 选择用 记事本打开。

注意:

这样修改 虚拟机镜像兼容性之后,还需要手工设置下镜像操作系统

先把这个虚拟机镜像 添加到本机虚拟机软件里面,(藏宝湾2022网游单机网www.jiaobenwang.com)

然后 按下图所示,根据这个镜像的 操作系统 实际情况 去设置一下 系统类型 版本。

这样就可以了。

注意, 这种VM一键端,第一次启动虚拟机镜像,会跳出一个窗口,要选择第一个【我已经移动该虚拟机】!!!

声明:
本站网游单机网-藏宝湾(www.jiaobenwang.com/www.cangbaowan.top)所有源码都来源于网络收集修改或者交换!本站所有程序、源码只供大家学习和研究软件内含的设计思想和原理之用,请下载后24小时内删除!。请大家不要用于商用及违法使用,否者如引起一切纠纷与本网站无关,后果自负!!
如果侵犯了您的权益,请及时告知我们(QQ: 18001103 email:[email protected]),我们即刻删除!
如遇到资源失效,请在此贴下方评论区留言,我们将尽快补充资源!
如遇资源实在不会架设,可以换其他游戏或者版本试试,不要纠结一个版本。


网游单机网-脚本王 » 【vm一键端基础】VMware低版本软件打开高版本软件生成的镜像时,提示版本不兼容 的解决办法

常见问题FAQ

什么叫一键端?
一般是虚拟机VM一键端或者windows一键启动服务端,适合新手!对于一键端来说,如果这个端是linux系统的,因为linux系统大家不熟悉,架设有点麻烦,所以很多人分享了自己架设服务端的linux系统镜像,这种叫VM一键端(虚拟机一键端)。 还有一种一键端是win系统的,大部分都是做好了启动服务端的快捷方式之类的,这种端实际和手工端相差不大了。win系统的一键端实际就是手工端!我个人认为如果端本身就是win系统的服务端,那就没必要去弄vm一键端了!
什么是手工端?
游戏服务端需手工安装配置,可以开服,适合老手,推荐方式!架设更有乐趣!
网单游戏有哪些架设方式?
1、单机玩耍,那么你只需要在你的电脑上 安装虚拟机软件+安卓模拟器即可。把服务端 运行在虚拟机的系统里面(如果是win服务端,也可以直接在电脑上运行服务端),客户端在安卓模拟器运行即可。各种VM一键端 基本就是用这种方式进行玩耍的!
2、局域网手机玩耍,局域网内,手机通过wifi连接你电脑上安装的服务端,离开这个wifi你就玩不了,这种方式虽然是局域网内可玩,但和外网架设实际上是一回事,都需要按照教程修改服务端、客户端。
3、外网玩耍,俗称开服,服务端架设在外网云服务器上,云服务器具有固定IP地址,通过手机安装客户端即可玩耍。

发表评论